dylan cali <> in Gradle

give testng unit test different name than junit

distinguishes the two in the integration tests and more accurately

reflects TestNG naming conventions

document --with testng java-library init modifier

reword setup modifier description now that more than one modifier is


implement java-library testng init modifier

    • -0
    • +1
add integration test for testng init modifier

rename SAMPLE_JUNIT_LIBRARY_TEST_CLASS to more generic

SAMPLE_LIBRARY_TEST_CLASS since the output path is the same regardles of java

framework being used

update Build Init Plugin userguide page

add section explaining init type modifiers

for each init type list modifiers supported or None

update build initialization design document

describe initialization modifiers functionality

generate supportedModifiers string lazily

only when it's actually needed for an error message

add test for default/bad init modifier error

implement support for init type modifiers

By default types do not support additional modifiers (and will fail with

an error message). However to support init modifiers the type

ProjectInitDescriptor implementation class simply needs to override the

withModifiers method and add handling logic in the generate method.

Currently only the java-library type supports init modifiers (spock).

add test for --with spock java-library init option