Clone Tools
  • last updated a few seconds ago
Constraints: committers
Constraints: files
Constraints: dates
Refactor getRelevantDependents to avoid fiddly nullable things

Avoid revisiting dependents

Use getAllDependentClasses instead of two identical loops

Use explicit accessibility for field so a field is generated by Groovy

Fix link to contributor

    • -1
    • +1
Merge remote-tracking branch 'origin/lacasseio/pr-10419'

* origin/lacasseio/pr-10419:

Add explicit constructor to avoid synthetic class generation

Mention contributor in release notes

Pass the mutating Set directly instead of a plain boolean

Split complex test into multiple tests

Clarify method's purpose with clearer name

Fix sample test failure

Use enum instead of the name string to compare the language

Improve readability of the tests

Improve incremental compilation for Java

    • -1
    • +2
Merge remote-tracking branch 'origin/sg/check/jdk-13'

* origin/sg/check/jdk-13:

Bump the check for which version of Gradle is compatible with JDK13

Mention CVE-2019-16370 in release notes

    • -1
    • +12
Bump the check for which version of Gradle is compatible with JDK13

5.6.x are considered newer than 5.6, so JDK13 tests attempt to run

against those versions.

Add explicit constructor to avoid synthetic class generation

Rename inheritStrictVersions() -> endorseStrictVersions() (#10755)

This name change more clearly communicates the semantics of the

feature from a users point of view.

This commit also removes all mentions of 'inheriting' AND 'forSubgraph'.

There have been some leftovers in documentation/comments that

would have been misleading in the future. To make sure we catch all,

this also updates all variable/method/package names.

  1. … 56 more files in changeset.
Merge pull request #10756 from gradle/revert-10546-lptr/validation/rename-validate-task-properties

Revert "Rename ValidateTaskProperties to ValidatePlugins"

Revert "Fix Gradleception"

This reverts commit 73e8c7de4e5ef0dcc3fcc302a20e0f15440963ef.

    • -1
    • +1
Revert "Rename ValidateTaskProperties to ValidatePlugins"

Merge pull request #10510 from gradle/jjohannes/modifiy-variants-of-components

Allow modifications to variants of components for publishing

Reword strict dependencies section

Fix Gradleception

    • -1
    • +1
Update documentation on forcing dependencies

Now that `force` is deprecated, we should recommend and

better describe the semantics of "strictly".

Rename ValidateTaskProperties to ValidatePlugins (#10546)

Rename ValidateTaskProperties to ValidatePlugins

Address review comments

Merge branch 'master' into lptr/validation/rename-validate-task-properties

Add reified extensions for ComponentMetadataHandler (#10739)

Proper example in Groovy and Kotlin DSL for disabling publishing

Fix test after adopting Property API

Use Property<Boolean> in ValidatePlugins

Link to user guide instead of repeating content in Javadoc.

Don't use lambda for task action

Remove group and description for nagger task

So that it doesn't show up in task lists.

Use instantiator for DSL objects created through SoftwareComponentFactory

To have a better and consistent DSL experience when using:

component.addVariantsFromConfiguration(...) { ... }

component.withVariantsFromConfiguration(...) { ... }

Rename ValidatePlugin to ValidatePlugins