Gradle

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Move remaining bits of `versioning.gradle` to `BuildVersionPlugin`

And move `BuildVersionPlugin` to the `plugins` project in the process so it has

access to the `buildTypes` extension.

Move remaining bits of `versioning.gradle` to `BuildVersionPlugin`

And move `BuildVersionPlugin` to the `plugins` project in the process so it has

access to the `buildTypes` extension.

Fix test

Fix test

Fix test

Merge branch 'master' into eskatos/kotlin/1.3.70-eap

Address missing kotlin eap repo in some tests

Signed-off-by: Paul Merlin <paul@gradle.com>

Address missing kotlin eap repo in some tests

Signed-off-by: Paul Merlin <paul@gradle.com>

Address missing kotlin eap repo in some tests

Signed-off-by: Paul Merlin <paul@gradle.com>

Address missing kotlin eap repo in some tests

Signed-off-by: Paul Merlin <paul@gradle.com>

Skip test that leaks file with instant execution enabled

Signed-off-by: Paul Merlin <paul@gradle.com>

WIP - spike exposing task execution plan details via build ops

WIP - spike exposing task execution plan details via build ops

WIP - spike exposing task execution plan details via build ops

Merge pull request #11872 from gradle/eskatos/ie/coverage-files-cleanup

Enable test coverage that was previously leaking files with instant execution

Update keyring file

Update keyring file

Adjust KotlinScriptCompilerTest to work with Kotlin 1.3.70

By moving the script template class to the top level.

Adjust `KotlinScriptCompilerTest` to work with the latest Kotlin 1.3.70 eap

By moving the script template class to the top level.

Adjust `KotlinScriptCompilerTest` to work with the latest Kotlin 1.3.70 eap

By moving the script template class to the top level.

Adjust KotlinScriptCompilerTest to work with Kotlin 1.3.70

By moving the script template class to the top level.

Adjust `KotlinScriptCompilerTest` to work with the latest Kotlin 1.3.70 eap

By moving the script template class to the top level.

Adjust `KotlinScriptCompilerTest` to work with the latest Kotlin 1.3.70 eap

By moving the script template class to the top level.

Cleanup distribution integration test

Now that we do dependency verification natively a large

part of this test is redundant.

Cleanup distribution integration test

Now that we do dependency verification natively a large

part of this test is redundant.

Extract common patterns into DeprecationWithReplacementBuilder

Upgrade embedded kotlin to 1.3.70-eap-42

Signed-off-by: Paul Merlin <paul@gradle.com>

Upgrade embedded kotlin to 1.3.70-eap-42

Signed-off-by: Paul Merlin <paul@gradle.com>

Upgrade embedded kotlin to 1.3.70-eap-42

Signed-off-by: Paul Merlin <paul@gradle.com>

Upgrade embedded kotlin to 1.3.70-eap-42

Signed-off-by: Paul Merlin <paul@gradle.com>