Gradle

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Increase cache layout version

Tweak error message.

Tweak error message.

Tweak error message.

Fix for convention mapping replacements.

Increase cache layout version

Remove `platform` dsl from constraint handler

These shortcuts define details of a dependency like attributes,

requested capabilities and 'endorse strict' status. These things

can not be defined on constraints. So these methods only cause

inconsistent behavior.

One can use constraints in combination with platforms like this to

control platform versions:

dependencies {

api platform("org:platform")

constraints {

api "org:platform:1.0"

}

}

Remove `platform` dsl from constraint handler

These shortcuts define details of a dependency like attributes,

requested capabilities and 'endorse strict' status. These things

can not be defined on constraints. So these methods only cause

inconsistent behavior.

One can use constraints in combination with platforms like this to

control platform versions:

dependencies {

api platform("org:platform")

constraints {

api "org:platform:1.0"

}

}

Remove `platform` dsl from constraint handler

These shortcuts define details of a dependency like attributes,

requested capabilities and 'endorse strict' status. These things

can not be defined on constraints. So these methods only cause

inconsistent behavior.

One can use constraints in combination with platforms like this to

control platform versions:

dependencies {

api platform("org:platform")

constraints {

api "org:platform:1.0"

}

}

    • -3
    • +0
    /subprojects/docs/src/docs/dsl/org.gradle.api.artifacts.dsl.DependencyConstraintHandler.xml
Remove `platform` dsl from constraint handler

These shortcuts define details of a dependency like attributes,

requested capabilities and 'endorse strict' status. These things

can not be defined on constraints. So these methods only cause

inconsistent behavior.

One can use constraints in combination with platforms like this to

control platform versions:

dependencies {

api platform("org:platform")

constraints {

api "org:platform:1.0"

}

}

Revert "Pin santaTracker to older version"

This reverts commit 0d2bc805958ccba24d835d5871f57a33025936f6.

    • -1
    • +1
    /subprojects/performance/templates.gradle
Fix NPE and tests

Fix NPE and tests

Decrease CachingPatternSpecFactory.RESULTS_CACHE_MAX_SIZE to 10000

Decrease CachingPatternSpecFactory.RESULTS_CACHE_MAX_SIZE to 10000

Decrease CachingPatternSpecFactory.RESULTS_CACHE_MAX_SIZE to 10000

Decrease CachingPatternSpecFactory.RESULTS_CACHE_MAX_SIZE to 10000

Decrease CachingPatternSpecFactory.RESULTS_CACHE_MAX_SIZE to 10000

Fix sample modifier to work with the new behavior

Increase cache layout version

Increase cache layout version

Increase cache layout version

Use a different 'shadow capability' for enforced platform

This allows both 'regular' and 'enforced' platform of the same

component to be selected. In order to make this work, support

for projects having shadow capability needed to be added.

Use a different 'shadow capability' for enforced platform

This allows both 'regular' and 'enforced' platform of the same

component to be selected. In order to make this work, support

for projects having shadow capability needed to be added.

Use a different 'shadow capability' for enforced platform

This allows both 'regular' and 'enforced' platform of the same

component to be selected. In order to make this work, support

for projects having shadow capability needed to be added.

Always apply all Category disambiguation rules

Before, parts of the platform disambiguation were only done when

using the 'java-platform' plugin. However, other consumers

may also require all rules (see #11091)

Always apply all Category disambiguation rules

Before, parts of the platform disambiguation were only done when

using the 'java-platform' plugin. However, other consumers

may also require all rules (see #11091)

Add tests to reproduce platform disambiguation issues in Gradle 6 RC1

See: https://github.com/gradle/gradle/issues/11091

Add tests to reproduce platform disambiguation issues in Gradle 6 RC1

See: https://github.com/gradle/gradle/issues/11091

Have FileSystemLocationSnapshots directly implement Node