Gradle

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Update application plugin to use lambdas and use new Provider API methods

Update application plugin to use lambdas and use new Provider API methods

Rename to proper method name

Rename to proper method name

Update released version to latest snapshot

Update version to 6.2

Merge remote-tracking branch 'origin/master-test' into release-test

Avoid more deprecated APIs

Avoid more deprecated APIs

Use the proper names for deprecated properties

Use the proper names for deprecated properties

Publish 6.0-20190926235010+0000

Remove more uses of deprecated API

Remove more uses of deprecated API

Replace use of archiveName with archiveFileName

  1. … 7 more files in changeset.
Restore old behavior of distribution plugin validation

Restore old behavior of distribution plugin validation

Restore old behavior of distribution plugin validation

Restore old behavior of distribution plugin validation

Restore old behavior of distribution plugin validation

Remove use of deprecated API

Use Provider API in Distribution plugin too

Use Provider API in Distribution plugin too

Use Provider API in Distribution plugin too

Use Provider API in Distribution plugin too

Use Provider API in Distribution plugin too

Prove Kotlin settings scripts support the Kotlin script API

Let precompiled init scripts support the Kotlin script API

Don't require reified type parameter for `Action.invoke` operator

In order to make it more broadly useful.

Prove precompiled script templates honor `HasImplicitReceiver`