Clone
Jendrik Johannes
committed
on 28 Apr
Remove test precondition: FIX_TO_WORK_ON_JAVA9
Gradle clearly works with Java 9 (and later) by now. There should
be nothing left to be fixed… Show more
Remove test precondition: FIX_TO_WORK_ON_JAVA9

Gradle clearly works with Java 9 (and later) by now. There should

be nothing left to be fixed. The remaining usages of this annotation

where wrong:

- The test is not testing a feature of Gradle, but of Java or another

 tool that only works with java versions < 9

 Replaced precondition with: JDK8_OR_EARLIER

 (or JDK9_OR_LATER depending on how it is used)

- Test is running older Gradle versions that do not support Java9+

 Replaced precondition with: JDK8_OR_EARLIER

- Test itself was using features of Java not available anymore in Java9+

 Removed precondition and fixed test to do the test setup differently.

Show less