ToolingApiDeprecatedProviderCrossVersionSpec.groovy

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Remove support for connecting to Gradle <2.6

    • -52
    • +0
    ./ToolingApiDeprecatedProviderCrossVersionSpec.groovy
  1. … 147 more files in changeset.
Deprecate TAPI consumer older than 3.0 (#2952)

https://github.com/gradle/gradle-private/issues/898

For TAPI consumer older than 3.0, DefaultConnection will output

deprecation message to consumer stdout.

    • -3
    • +3
    ./ToolingApiDeprecatedProviderCrossVersionSpec.groovy
  1. … 8 more files in changeset.
Fix failed cross version tests (#2950)

Fix failed cross version tests

    • -3
    • +3
    ./ToolingApiDeprecatedProviderCrossVersionSpec.groovy
  1. … 2 more files in changeset.
Deprecate support for old TAPI providers (#2913)

Deprecation TAPI provider older than 2.6

https://github.com/gradle/gradle-private/issues/898

This change deprecates running Gradle older than 2.6 via Tooling API

    • -0
    • +52
    ./ToolingApiDeprecatedProviderCrossVersionSpec.groovy
  1. … 11 more files in changeset.