Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Let tooling-api cross-version tests not use deprecated configurations

    • -1
    • +1
    ./ToolingApiVersionSpecification.groovy
  1. … 17 more files in changeset.
Let tooling-api cross-version tests not use deprecated configurations

    • -1
    • +1
    ./ToolingApiVersionSpecification.groovy
  1. … 17 more files in changeset.
Let tooling-api tests not use deprecated configurations

    • -1
    • +1
    ./ToolingApiVersionSpecification.groovy
  1. … 6 more files in changeset.
Let tooling-api tests not use deprecated configurations

    • -1
    • +1
    ./ToolingApiVersionSpecification.groovy
  1. … 19 more files in changeset.
Let tooling-api tests not use deprecated configurations

    • -1
    • +1
    ./ToolingApiVersionSpecification.groovy
  1. … 6 more files in changeset.
Let tooling-api tests not use deprecated configurations

    • -1
    • +1
    ./ToolingApiVersionSpecification.groovy
  1. … 6 more files in changeset.
Let tooling-api tests not use deprecated configurations

    • -1
    • +1
    ./ToolingApiVersionSpecification.groovy
  1. … 19 more files in changeset.
Let tooling-api tests not use deprecated configurations

    • -1
    • +1
    ./ToolingApiVersionSpecification.groovy
  1. … 19 more files in changeset.
Fix TAPI handling of the client provided system input `InputStream` when running in embedded mode. Previously this input stream would be ignored.

    • -1
    • +5
    ./CapturingUserInputCrossVersionSpec.groovy
  1. … 9 more files in changeset.
Fix TAPI handling of the client provided system input `InputStream` when running in embedded mode. Previously this input stream would be ignored.

    • -1
    • +5
    ./CapturingUserInputCrossVersionSpec.groovy
  1. … 9 more files in changeset.
Fix TAPI handling of the client provided system input `InputStream` when running in embedded mode. Previously this input stream would be ignored.

    • -1
    • +5
    ./CapturingUserInputCrossVersionSpec.groovy
  1. … 9 more files in changeset.
Fix TAPI handling of the client provided system input `InputStream` when running in embedded mode. Previously this input stream would be ignored.

    • -1
    • +5
    ./CapturingUserInputCrossVersionSpec.groovy
  1. … 9 more files in changeset.
Fix TAPI handling of the client provided system input `InputStream` when running in embedded mode. Previously this input stream would be ignored.

    • -1
    • +5
    ./CapturingUserInputCrossVersionSpec.groovy
  1. … 9 more files in changeset.
Fix TAPI handling of the client provided system input `InputStream` when running in embedded mode. Previously this input stream would be ignored.

    • -1
    • +5
    ./CapturingUserInputCrossVersionSpec.groovy
  1. … 9 more files in changeset.
Fix TAPI handling of the client provided system input `InputStream` when running in embedded mode. Previously this input stream would be ignored.

    • -1
    • +5
    ./CapturingUserInputCrossVersionSpec.groovy
  1. … 9 more files in changeset.
Fix TAPI handling of the client provided system input `InputStream` when running in embedded mode. Previously this input stream would be ignored.

    • -1
    • +5
    ./CapturingUserInputCrossVersionSpec.groovy
  1. … 9 more files in changeset.
Revert changes to tests only added to remember an exception for retry

This is now automatically done in the ToolingApiSpecification

test fixture.

    • -12
    • +13
    ./ToolingApiUnsupportedConsumerCrossVersionSpec.groovy
    • -8
    • +9
    ./ToolingApiUnsupportedProviderCrossVersionSpec.groovy
  1. … 4 more files in changeset.
Revert changes to tests only added to remember an exception for retry

This is now automatically done in the ToolingApiSpecification

test fixture.

    • -12
    • +13
    ./ToolingApiUnsupportedConsumerCrossVersionSpec.groovy
    • -8
    • +9
    ./ToolingApiUnsupportedProviderCrossVersionSpec.groovy
  1. … 4 more files in changeset.
Add some test coverage to show that the TAPI is well behaved when a test execution request is received from an unsupported TAPI client version (<3.0).

    • -5
    • +15
    ./ToolingApiUnsupportedConsumerCrossVersionSpec.groovy
Remove support for TAPI clients <3.0

    • -60
    • +0
    ./ToolingApiDeprecatedConsumerCrossVersionSpec.groovy
    • -8
    • +8
    ./ToolingApiUnsupportedConsumerCrossVersionSpec.groovy
  1. … 62 more files in changeset.
Remove support for connecting to Gradle <2.6

    • -52
    • +0
    ./ToolingApiDeprecatedProviderCrossVersionSpec.groovy
    • -2
    • +2
    ./ToolingApiUnsupportedConsumerCrossVersionSpec.groovy
    • -32
    • +12
    ./ToolingApiUnsupportedProviderCrossVersionSpec.groovy
  1. … 145 more files in changeset.
Raise version to 5.0

    • -2
    • +2
    ./ToolingApiVersionSpecification.groovy
  1. … 24 more files in changeset.
Initialize outputStream in setup method

so the re-run rule resets the output stream

    • -1
    • +5
    ./ToolingApiVersionSpecification.groovy
Change version of parameterized models to 4.4

This commit modifies all the java docs and concerned files in previous

commits in this pull request.

    • -214
    • +0
    ./CustomParameterizedToolingModelCrossVersion.groovy
  1. … 25 more files in changeset.
Don't ask for user input on non-interactive console (#3106)

    • -0
    • +83
    ./CapturingUserInputCrossVersionSpec.groovy
  1. … 13 more files in changeset.
Fix TAPI integration tests

    • -0
    • +501
    ./PluginApplicationBuildProgressCrossVersionSpec.groovy
  1. … 2 more files in changeset.
Deprecate TAPI consumer older than 3.0 (#2952)

https://github.com/gradle/gradle-private/issues/898

For TAPI consumer older than 3.0, DefaultConnection will output

deprecation message to consumer stdout.

    • -0
    • +60
    ./ToolingApiDeprecatedConsumerCrossVersionSpec.groovy
    • -3
    • +3
    ./ToolingApiDeprecatedProviderCrossVersionSpec.groovy
    • -0
    • +73
    ./ToolingApiUnsupportedConsumerCrossVersionSpec.groovy
    • -20
    • +29
    ./ToolingApiVersionSpecification.groovy
  1. … 5 more files in changeset.
Change version of parameterized models to 4.3

This commit modifies all the java docs and concerned files in previous

commits.

    • -0
    • +24
    ./CustomParameter.java
    • -0
    • +214
    ./CustomParameterizedToolingModelCrossVersion.groovy
    • -0
    • +31
    ./InvalidModel2Action.java
    • -0
    • +48
    ./MultipleParametersAction.java
    • -0
    • +27
    ./NoParameterAction.java
    • -0
    • +33
    ./ParameterAction.java
  1. … 25 more files in changeset.
Fix failed cross version tests (#2950)

Fix failed cross version tests

    • -3
    • +3
    ./ToolingApiDeprecatedProviderCrossVersionSpec.groovy
    • -4
    • +0
    ./ToolingApiVersionSpecification.groovy
  1. … 1 more file in changeset.
Deprecate support for old TAPI providers (#2913)

Deprecation TAPI provider older than 2.6

https://github.com/gradle/gradle-private/issues/898

This change deprecates running Gradle older than 2.6 via Tooling API

    • -0
    • +52
    ./ToolingApiDeprecatedProviderCrossVersionSpec.groovy
    • -0
    • +83
    ./ToolingApiUnsupportedProviderCrossVersionSpec.groovy
    • -0
    • +86
    ./ToolingApiVersionSpecification.groovy
  1. … 9 more files in changeset.