Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Remove support for connecting to Gradle <2.6

    • -49
    • +0
    ./BuildResultTasksFeatureCheckTest.groovy
  1. … 147 more files in changeset.
Move to subpackage

+review REVIEW-5698

    • -1
    • +0
    ./BuildResultOutputFeatureCheckTest.groovy
    • -1
    • +0
    ./BuildResultTasksFeatureCheckTest.groovy
  1. … 7 more files in changeset.
Fail the build if build result output is accessed with Gradle < 2.9 in debug mode

+review REVIEW-5698

    • -6
    • +15
    ./BuildResultOutputFeatureCheckTest.groovy
    • -4
    • +4
    ./BuildResultTasksFeatureCheckTest.groovy
  1. … 18 more files in changeset.
Only fail test execution for features when they are used

TestKit aims to be able to execute builds with fairly old Gradle target versions e.g. 1.0. However, particular TestKit features might not be available for a specific target Gradle versions. In those cases throw an exception when a functionality is accessed by the user but allow the actual execution of the build.

+review REVIEW-5698

    • -0
    • +50
    ./BuildResultOutputFeatureCheckTest.groovy
    • -0
    • +50
    ./BuildResultTasksFeatureCheckTest.groovy
  1. … 11 more files in changeset.