GradleRunnerSupportedBuildJvmIntegrationTest.groovy

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Rename method/test to reflect Java 8 requirement

    • -1
    • +1
    ./GradleRunnerSupportedBuildJvmIntegrationTest.groovy
  1. … 1 more file in changeset.
Raise minimum build JVM version to Java 8

    • -3
    • +3
    ./GradleRunnerSupportedBuildJvmIntegrationTest.groovy
  1. … 30 more files in changeset.
Ignore test if no 1.5 or 1.6 JDK is found

    • -0
    • +2
    ./GradleRunnerSupportedBuildJvmIntegrationTest.groovy
  1. … 2 more files in changeset.
Simplified several int tests that check for behaviour when attempting to run on Java 5 or Java 6.

    • -5
    • +6
    ./GradleRunnerSupportedBuildJvmIntegrationTest.groovy
  1. … 3 more files in changeset.
Removed unused import.

    • -1
    • +0
    ./GradleRunnerSupportedBuildJvmIntegrationTest.groovy
Changed the minimum version that Gradle will run on to Java 7.

    • -3
    • +9
    ./GradleRunnerSupportedBuildJvmIntegrationTest.groovy
  1. … 15 more files in changeset.
Don't run this test for old Gradle versions.

    • -0
    • +2
    ./GradleRunnerSupportedBuildJvmIntegrationTest.groovy
Removed test broken on Java 6, pending a better test case for this.

    • -12
    • +0
    ./GradleRunnerSupportedBuildJvmIntegrationTest.groovy
Added some test coverage that a deprecation warning is received when using testkit to run a build on java 6.

    • -0
    • +48
    ./GradleRunnerSupportedBuildJvmIntegrationTest.groovy