test-kit

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Migrate to JUnit5 Vintage (#13297)

### Context

We made an attempt to migrate to JUnit5 but failed by incompatibility between JUnit5 and Spock `@Unroll` tests. All works fine on CI, but if you right click a Spock `@Unroll` test in IDEA, it didn't work. This PR workarounds this issue by falling back to JUnit in IDEA.

  1. … 15 more files in changeset.
Distributed test

  1. … 113 more files in changeset.
Distributed test

  1. … 113 more files in changeset.
Migrate to JUnit5 Vintage

  1. … 6 more files in changeset.
Migrate to JUnit5 Vintage

  1. … 5 more files in changeset.
Migrate to JUnit5 Vintage

  1. … 6 more files in changeset.
Migrate to JUnit5 Vintage

  1. … 8 more files in changeset.
[WiP] Explicitly declare different Gradle distributions for testing

  1. … 144 more files in changeset.
[WiP] Explicitly declare different Gradle distributions for testing

  1. … 163 more files in changeset.
[WiP] Explicitly declare different Gradle distributions for testing

  1. … 167 more files in changeset.
[WiP] Explicitly declare different Gradle distributions for testing

  1. … 222 more files in changeset.
[WiP] Explicitly declare different Gradle distributions for testing