Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Move Deleter interface out of impl package

  1. … 41 more files in changeset.
Move Deleter interface out of impl package

  1. … 38 more files in changeset.
Make `SourceDistributionResolver` compatible with an yet to published major.0 version

    • -18
    • +26
    ./kotlin/dsl/resolver/SourceDistributionProvider.kt
  1. … 1 more file in changeset.
Add notInheritConstraints() to module dependency API

  1. … 5 more files in changeset.
Adjust `SourceDistributionResolverIntegrationTest` not fail before a major release

By explicitly setting the minimum version to use for resolving the

source distribution to the previous major Gradle version in the test.

  1. … 1 more file in changeset.
Remove FindBugs and JDepend plugins from Gradle distribution (#10201)

    • -4
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 64 more files in changeset.
Remove FindBugs and JDepend plugins from Gradle distribution

    • -4
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 64 more files in changeset.
Remove announce plugin

    • -2
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 65 more files in changeset.
Remove announce plugin

    • -2
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 65 more files in changeset.
Introduce constraint inheritance API

  1. … 40 more files in changeset.
Introduce constraint inheritance API

  1. … 40 more files in changeset.
Introduce constraint inheritance API

  1. … 40 more files in changeset.
Create Deleter as a service

  1. … 11 more files in changeset.
Introduce constraint inheritance API

  1. … 41 more files in changeset.
Remove osgi plugin

    • -2
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 41 more files in changeset.
Remove osgi plugin

    • -2
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 41 more files in changeset.
Remove play framework support from Gradle distribution

This is superseded by: https://gradle.github.io/playframework/

This commit removes:

- The `platform-play` and `ide-play` subprojects

- The documentation for the functionality provided by these projects

    • -6
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 502 more files in changeset.
Remove play framework support from Gradle distribution

This is superseded by: https://gradle.github.io/playframework/

This commit removes:

- The `platform-play` and `ide-play` subprojects

- The documentation for the functionality provided by these projects

    • -6
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 499 more files in changeset.
Remove play framework support from Gradle distribution

This is superseded by: https://gradle.github.io/playframework/

This commit removes:

- The `platform-play` and `ide-play` subprojects

- The documentation for the functionality provided by these projects

    • -6
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 508 more files in changeset.
Remove play framework support from Gradle distribution

This is superseded by: https://gradle.github.io/playframework/

This commit removes:

- The `platform-play` and `ide-play` subprojects

- The documentation for the functionality provided by these projects

    • -6
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 503 more files in changeset.
Remove play framework support from Gradle distribution

This is superseded by: https://gradle.github.io/playframework/

This commit removes:

- The `platform-play` and `ide-play` subprojects

- The documentation for the functionality provided by these projects

    • -6
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 503 more files in changeset.
Remove play framework support from Gradle distribution

This is superseded by: https://gradle.github.io/playframework/

This commit removes:

- The `platform-play` and `ide-play` subprojects

- The documentation for the functionality provided by these projects

    • -6
    • +0
    ./kotlin/dsl/codegen/PluginIdExtensions.kt
  1. … 499 more files in changeset.
Favour unboxed Kotlin range accessors

    • -1
    • +1
    ./kotlin/dsl/execution/PartialEvaluator.kt
    • -1
    • +1
    ./kotlin/dsl/execution/ProgramParser.kt
    • -8
    • +8
    ./kotlin/dsl/execution/ProgramSource.kt
Revert "Merge pull request #9759 from gradle/eskatos/kotlin/1.3.40"

This reverts commit 2c6fb9495acea6a150ad313ed3474ebc3689b920, reversing

changes made to 8959fc43370bc5141db6f775b333f36d30cc42a1.

    • -5
    • +3
    ./kotlin/dsl/support/KotlinCompiler.kt
  1. … 23 more files in changeset.
Allow package declarations in Kotlin DSL scripts

In order to make it possible to `apply(from = "...")` a script that

plays the dual role of local script and precompiled script plugin.

Multi-stage scripts are not supported, more specifically, a script

with a `plugins` block or `buildscript` block will throw `CNFE` at

runtime.

    • -59
    • +60
    ./kotlin/dsl/execution/ProgramParser.kt
  1. … 6 more files in changeset.
Allow package declarations in Kotlin DSL scripts

In order to make it possible to `apply(from = "...")` a script that

plays the dual role of local script and precompiled script plugin.

Multi-stage scripts are not supported, more specifically, a script

with a `plugins` block or `buildscript` block will throw `CNFE` at

runtime.

    • -59
    • +60
    ./kotlin/dsl/execution/ProgramParser.kt
  1. … 6 more files in changeset.
Deprecating buildSrc usage in settings (#9898)

* Fix sanityCheck

* Handle deprecated use of resources from buildSrc in settings

* Address some feedback from PR review

* Simplify deprecation warning

* ensure only fired once for performance reasons

* tweak test coverage

* add proper test coverage

* use simplified deprecation warning

* ensure works with kotlin-ds;

* Fix caching of deprecated classloader

* use uniqye identifier and avoid same identifier as non deprecated loader

* fix more tests now expecting deprecation warning

* Make DeprecatedClassloader closeable

* Mention deprecation in upgrade guide

  1. … 23 more files in changeset.
Add `inheritSubgraphConstraints()` API to dependencies

  1. … 61 more files in changeset.
Add `inheritSubgraphConstraints()` API to dependencies

  1. … 62 more files in changeset.
Add `inheritSubgraphConstraints()` API to dependencies

  1. … 63 more files in changeset.