Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Rename API for silencing publication warnings

* New name indicates better that these warnings are about the non Gradle

metadata formats.

  1. … 5 more files in changeset.
Rename API for silencing publication warnings

* New name indicates better that these warnings are about the non Gradle

metadata formats.

  1. … 5 more files in changeset.
Improve publication warning message

* Clarify this impacts POM and Ivy format, not Gradle Module Metadata

* Clean up tests

  1. … 4 more files in changeset.
Improve publication warning message

* Clarify this impacts POM and Ivy format, not Gradle Module Metadata

* Clean up tests

  1. … 4 more files in changeset.
Improve publication warning message

* Clarify this impacts POM and Ivy format, not Gradle Module Metadata

* Clean up tests

  1. … 4 more files in changeset.
Improve publication warning message

* Clarify this impacts POM and Ivy format, not Gradle Module Metadata

* Clean up tests

  1. … 4 more files in changeset.
Updates to terminology for clarity

- `inheritStrictConstraints` -> `inheritStrictVersions`

- `notInheritStrictConstraints` -> `doNotInheritStrictVersions`

    • -3
    • +3
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 31 more files in changeset.
Updates to terminology for clarity

- `inheritStrictConstraints` -> `inheritStrictVersions`

- `notInheritStrictConstraints` -> `doNotInheritStrictVersions`

    • -3
    • +3
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 31 more files in changeset.
Updates to terminology for clarity

- `inheritStrictConstraints` -> `inheritStrictVersions`

- `notInheritStrictConstraints` -> `doNotInheritStrictVersions`

    • -3
    • +3
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 31 more files in changeset.
Updates to terminology for clarity

- `inheritStrictConstraints` -> `inheritStrictVersions`

- `notInheritStrictConstraints` -> `doNotInheritStrictVersions`

    • -3
    • +3
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 31 more files in changeset.
Updates to terminology for clarity

- `inheritStrictConstraints` -> `inheritStrictVersions`

- `notInheritStrictConstraints` -> `doNotInheritStrictVersions`

    • -3
    • +3
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 31 more files in changeset.
Updates to terminology for clarity

- `inheritStrictConstraints` -> `inheritStrictVersions`

- `notInheritStrictConstraints` -> `doNotInheritStrictVersions`

    • -3
    • +3
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 30 more files in changeset.
Rework `forSubgraph` as implied by `strictly`

This commit removes a dedicated `forSubgraph` flag

on version constraints, so that it is _implied_ by

strict version constraints. This simplifies the behavior

of `strictly`, making it closer to the intuitive semantics,

while maintaining the ability to fail the build if a

consumer brings an incompatible version in the graph.

As a consequence, _strict dependencies_ now express that

the producer preference overrides whatever is found in

its own dependency graph. It is closer to the "nearest

first" semantics of Maven, while not having its drawbacks

(ordering in particular).

    • -13
    • +10
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 77 more files in changeset.
Rework `forSubgraph` as implied by `strictly`

This commit removes a dedicated `forSubgraph` flag

on version constraints, so that it is _implied_ by

strict version constraints. This simplifies the behavior

of `strictly`, making it closer to the intuitive semantics,

while maintaining the ability to fail the build if a

consumer brings an incompatible version in the graph.

As a consequence, _strict dependencies_ now express that

the producer preference overrides whatever is found in

its own dependency graph. It is closer to the "nearest

first" semantics of Maven, while not having its drawbacks

(ordering in particular).

    • -13
    • +10
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 79 more files in changeset.
Rework `forSubgraph` as implied by `strictly`

This commit removes a dedicated `forSubgraph` flag

on version constraints, so that it is _implied_ by

strict version constraints. This simplifies the behavior

of `strictly`, making it closer to the intuitive semantics,

while maintaining the ability to fail the build if a

consumer brings an incompatible version in the graph.

As a consequence, _strict dependencies_ now express that

the producer preference overrides whatever is found in

its own dependency graph. It is closer to the "nearest

first" semantics of Maven, while not having its drawbacks

(ordering in particular).

    • -13
    • +10
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 77 more files in changeset.
Rework `forSubgraph` as implied by `strictly`

This commit removes a dedicated `forSubgraph` flag

on version constraints, so that it is _implied_ by

strict version constraints. This simplifies the behavior

of `strictly`, making it closer to the intuitive semantics,

while maintaining the ability to fail the build if a

consumer brings an incompatible version in the graph.

As a consequence, _strict dependencies_ now express that

the producer preference overrides whatever is found in

its own dependency graph. It is closer to the "nearest

first" semantics of Maven, while not having its drawbacks

(ordering in particular).

    • -13
    • +10
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 77 more files in changeset.
Rework `forSubgraph` as implied by `strictly`

This commit removes a dedicated `forSubgraph` flag

on version constraints, so that it is _implied_ by

strict version constraints. This simplifies the behavior

of `strictly`, making it closer to the intuitive semantics,

while maintaining the ability to fail the build if a

consumer brings an incompatible version in the graph.

As a consequence, _strict dependencies_ now express that

the producer preference overrides whatever is found in

its own dependency graph. It is closer to the "nearest

first" semantics of Maven, while not having its drawbacks

(ordering in particular).

    • -13
    • +10
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 77 more files in changeset.
Rework `forSubgraph` as implied by `strictly`

This commit removes a dedicated `forSubgraph` flag

on version constraints, so that it is _implied_ by

strict version constraints. This simplifies the behavior

of `strictly`, making it closer to the intuitive semantics,

while maintaining the ability to fail the build if a

consumer brings an incompatible version in the graph.

As a consequence, _strict dependencies_ now express that

the producer preference overrides whatever is found in

its own dependency graph. It is closer to the "nearest

first" semantics of Maven, while not having its drawbacks

(ordering in particular).

    • -13
    • +10
    ./gradle/api/publish/ivy/IvyGradleModuleMetadataPublishIntegrationTest.groovy
  1. … 77 more files in changeset.
Merge branch 'feature/JLL/depricate_http_download_dependencies' of https://github.com/JLLeitschuh/gradle

* 'feature/JLL/depricate_http_download_dependencies' of https://github.com/JLLeitschuh/gradle:

Fix failing tests from insecure HTTP deprecation changes

Fix failing tests from insecure HTTP deprecation changes

Fix DefaultFlatDirArtifactRepositoryTest

Refactor HTTP deprecation logic to use HttpRedirectVerifier

Add link to medium publication about industry wide MITM

Update `@since` for new API's to be since 6.0

Disable HTTP support for TextResources in redirects by default

Fix newly added API's to use `@since 5.7`

Revert "Revert "Merge remote-tracking branch 'origin/sg/merges/pr-9419'""

  1. … 11 more files in changeset.
Add API for silencing publication warnings

* API is per variant or all warnings

Fixes #9378

Fixes #10431

  1. … 6 more files in changeset.
Add API for silencing publication warnings

* API is per variant or all warnings

Fixes #9378

Fixes #10431

  1. … 6 more files in changeset.
Add API for silencing publication warnings

* API is per variant or all warnings

Fixes #9378

Fixes #10431

  1. … 6 more files in changeset.
Add API for silencing publication warnings

* API is per variant or all warnings

Fixes #9378

Fixes #10431

  1. … 6 more files in changeset.
Add API for silencing publication warnings

* API is per variant or all warnings

Fixes #9378

Fixes #10431

  1. … 6 more files in changeset.
Add API for silencing publication warnings

* API is per variant or all warnings

Fixes #9378

Fixes #10431

  1. … 6 more files in changeset.
Add API for silencing publication warnings

* API is per variant or all warnings

Fixes #9378

Fixes #10431

  1. … 6 more files in changeset.
Rework publication compatibility warnings

* Group by variant

* Isolate variant level warnings

Issue #9378

  1. … 5 more files in changeset.
Rework publication compatibility warnings

* Group by variant

* Isolate variant level warnings

Issue #9378

  1. … 5 more files in changeset.
Rework publication compatibility warnings

* Group by variant

* Isolate variant level warnings

Issue #9378

  1. … 5 more files in changeset.
Rework publication compatibility warnings

* Group by variant

* Isolate variant level warnings

Issue #9378

  1. … 5 more files in changeset.