upgrading_version_4.adoc

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Organize user guide sources in folders

  1. … 173 more files in changeset.
Split up 'publishing'

  1. … 15 more files in changeset.
Remove FindBugs and JDepend plugins from Gradle distribution (#10201)

  1. … 64 more files in changeset.
Remove FindBugs and JDepend plugins from Gradle distribution

  1. … 64 more files in changeset.
Reorganize the "publishing" section

Integrate it into the dependency management docs.

This commit also adds documentation about custom component publication.

  1. … 22 more files in changeset.
Reorganize the "publishing" section

Integrate it into the dependency management docs.

This commit also adds documentation about custom component publication.

  1. … 22 more files in changeset.
Fix dead link detector

* Requires all link to have at least one # in them

* Support links to a different file, no anchor, ending with #

* Support links within the same file, starting with #

* Support links without replacement text

* Support links where the file extension is omitted

And fix all detected dead links ...

  1. … 23 more files in changeset.
Fix dead link detector

* Requires all link to have at least one # in them

* Support links to a different file, no anchor, ending with #

* Support links within the same file, starting with #

* Support links without replacement text

* Support links where the file extension is omitted

And fix all detected dead links ...

  1. … 22 more files in changeset.
Add anchor check to dead link tasks

* Improve dead links detector

* Fix dead links

  1. … 45 more files in changeset.
Add anchor check to dead link tasks

* Improve dead links detector

* Fix dead links

* Make dead link detection a build step

  1. … 41 more files in changeset.
Add anchor check to dead link tasks

* Improve dead links detector

* Fix dead links

  1. … 45 more files in changeset.
Add anchor check to dead link tasks

* Improve dead links detector

* Fix dead links

  1. … 45 more files in changeset.
Fix dead internal links

  1. … 28 more files in changeset.
Fix dead internal links

  1. … 28 more files in changeset.
Fix dead internal links

  1. … 28 more files in changeset.
Fix dead internal links

  1. … 28 more files in changeset.
Change a few Groovy HTTP links in docs to HTTPS

  1. … 6 more files in changeset.
Change a few Groovy HTTP links in docs to HTTPS

  1. … 17 more files in changeset.
Revert "Use HTTPS for links to groovy docs from Javadoc"

This reverts commit 35342c85e520ea81ccc307743a40c053c957b99e.

  1. … 11 more files in changeset.
Use HTTPS for links to groovy docs from Javadoc

  1. … 11 more files in changeset.
Fix broken link in upgrade guide

Merge pull request #8347 from pvliss/gh-7815

Add note to upgrade guide to not try upgrading to 5.0 and switching to the Kotlin DSL at the same time

Add note to upgrade guide to not try upgrading to 5.0 and switching to the Kotlin DSL at the same time

Issue #7815

Signed-off-by: Panayiotis Vlissidis <pvlissidis@gmail.com>

Doc updates: deprecations in AbstractArchiveTask

This commit contains the userguide and javadoc updates following the

deprecations in AbstractArchiveTask.

Samples are also updated to no longer use any deprecated API.

Issue #8217

  1. … 24 more files in changeset.
Recommend Android Studio 3.3

instead of 3.4

3.3 rcs now support Gradle 5

Signed-off-by: Paul Merlin <paul@gradle.com>

rework 4.X upgrade guide

- add section header for preamble

- expand explanation of why users should upgrade to 4.10.2 first

- change link at the top to send users to upgrading from 4.9 section instead of 4.10

- copy missing breaking changes from preamble to the upgrading from 4.10 section

Update upgrade guide to mention 4.10.3 as latest 4.10

update note about min android studio version

Move the Android Studio information into a callout and add that the minimum version is for both Android Studio and the Android Gradle Plugin

Add Android Studio compatibility note

Gradle 5.0 requires Android Studio 3.3 or higher.

Upgrade to Groovy 2.5.4

Resolves #7711.

  1. … 1 more file in changeset.