Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Bump default PMD version to 6.23.0 (#12956)

This also fixes the multi-version PMD test setup:

The tests where not configured correctly for running older PMD versions

that do not support incremental analysis.

Also, tests changed the source compatibility for ALL PMD versions to 7,

although newer versions support current Java versions.

  1. … 7 more files in changeset.
Bump default PMD version to 6.23.0

This also fixes the multi-version PMD test setup:

The tests where not configured correctly for running older PMD versions

that do not support incremental analysis.

Also, tests changed the source compatibility for ALL PMD versions to 7,

although newer versions support current Java versions.

  1. … 7 more files in changeset.
Bump default PMD version to 6.23.0

This also fixes the multi-version PMD test setup:

The tests where not configured correctly for running older PMD versions

that do not support incremental analysis.

Also, tests changed the source compatibility for ALL PMD versions to 7,

although newer versions support current Java versions.

  1. … 7 more files in changeset.
Bump default PMD version to 6.23.0

This also fixes the multi-version PMD test setup:

The tests where not configured correctly for running older PMD versions

that do not support incremental analysis.

Also, tests changed the source compatibility for ALL PMD versions to 7,

although newer versions support current Java versions.

  1. … 7 more files in changeset.
Bump default PMD version to 6.23.0

This also fixes the multi-version PMD test setup:

The tests where not configured correctly for running older PMD versions

that do not support incremental analysis.

Also, tests changed the source compatibility for ALL PMD versions to 7,

although newer versions support current Java versions.

  1. … 7 more files in changeset.
Bump default PMD version to 6.23.0

This also fixes the multi-version PMD test setup:

The tests where not configured correctly for running older PMD versions

that do not support incremental analysis.

Also, tests changed the source compatibility for ALL PMD versions to 7,

although newer versions support current Java versions.

  1. … 7 more files in changeset.
Bump default PMD version to 6.23.0

This also fixes the multi-version PMD test setup:

The tests where not configured correctly for running older PMD versions

that do not support incremental analysis.

Also, tests changed the source compatibility for ALL PMD versions to 7,

although newer versions support current Java versions.

  1. … 7 more files in changeset.
Bump default PMD version to 6.23.0

This also fixes the multi-version PMD test setup:

The tests where not configured correctly for running older PMD versions

that do not support incremental analysis.

Also, tests changed the source compatibility for ALL PMD versions to 7,

although newer versions support current Java versions.

  1. … 7 more files in changeset.
Improve error message when PMD incremental analysis is enabled on older version of PMD

  1. … 2 more files in changeset.
Enable PMD incrementalAnalysis by default

* Enable by default

* Remove `@Incubating` from APIs

* Add release notes

  1. … 2 more files in changeset.
Enable PMD incrementalAnalysis by default

* Enable by default

* Remove `@Incubating` from APIs

* Add release notes

  1. … 2 more files in changeset.
Do not use ConventionMapping with Property types

Remove unused import

Add Groovy version constraint to CodeNarc plugin

  1. … 1 more file in changeset.
Revert "Force latest Groovy in Codenarc tests only without touching the plugin itself"

This reverts commit 68eb29a0e3104674b81815d8d8e7ebf35e7de692.

  1. … 6 more files in changeset.
Force current Groovy version in tests for CodeNarc if running in JDK14

  1. … 6 more files in changeset.
Force latest Groovy in Codenarc tests only without touching the plugin itself

  1. … 6 more files in changeset.
Force current Groovy version for CodeNarc plugin 1.5 so that it works with JDK14

  1. … 1 more file in changeset.
Force current Groovy version for CodeNarc plugin 1.5 so that it works with JDK14

  1. … 1 more file in changeset.
Force current Groovy version for CodeNarc plugin 1.5 so that it works with JDK14

  1. … 5 more files in changeset.
Force current Groovy version for CodeNarc plugin 1.5 so that it works with JDK14

  1. … 5 more files in changeset.
Simplify PmdPlugin

Bump version of PMD to 6.21.0

  1. … 1 more file in changeset.
Specify in method signature the Gradle version when a feature will be deprecated

  1. … 66 more files in changeset.
Upgrade default CodeNarc version to 1.5 (#12251)

Upgrade default CodeNarc version to 1.5 (#12251)

Whitespace

Signed-off-by: Paul Merlin <paul@gradle.com>

  1. … 5 more files in changeset.
Whitespace

Signed-off-by: Paul Merlin <paul@gradle.com>

  1. … 5 more files in changeset.
Whitespace

Signed-off-by: Paul Merlin <paul@gradle.com>

  1. … 5 more files in changeset.
Require deprecation timeline to be specified when building a deprecation message

  1. … 69 more files in changeset.