AbstractPmdPluginVersionIntegrationTest.groovy

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Workaround issues with PMD inspecting Gradle's classpath

    • -1
    • +1
    ./AbstractPmdPluginVersionIntegrationTest.groovy
  1. … 3 more files in changeset.
Workaround issues with PMD inspecting Gradle's classpath

    • -1
    • +1
    ./AbstractPmdPluginVersionIntegrationTest.groovy
  1. … 3 more files in changeset.
Rework after reintroducing reverted changes

    • -0
    • +3
    ./AbstractPmdPluginVersionIntegrationTest.groovy
  1. … 6 more files in changeset.
Upgrade default tool version of PMD to 6.7.0

The default ruleset has been changed from the now deprecated

`java-basic` to `category/java/errorprone.xml`.

Resolves #6625.

    • -1
    • +1
    ./AbstractPmdPluginVersionIntegrationTest.groovy
  1. … 9 more files in changeset.
Support PMD incremental analysis

    • -1
    • +4
    ./AbstractPmdPluginVersionIntegrationTest.groovy
  1. … 9 more files in changeset.
Put code quality integration tests into separate packages

    • -0
    • +40
    ./AbstractPmdPluginVersionIntegrationTest.groovy
  1. … 45 more files in changeset.