build-environment.kt

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Upgrade Kotlin DSL to 1.1.1

Signed-off-by: Rodrigo B. de Oliveira <rodrigo@gradle.com>

Let buildSrc kotlin code satisfy type/file name ktlint rule

those files only contains a single type

they should be named accordingly

Signed-off-by: Paul Merlin <paul@gradle.com>

  1. … 5 more files in changeset.
Upgrade Kotlin DSL to 1.1.0

Signed-off-by: Rodrigo B. de Oliveira <rodrigo@gradle.com>

Upgrade Kotlin DSL to 1.0.5 and Kotlin to 1.3.11

Add support for kotlin lambdas as deferred construct in the Gradle API

support is enabled when the Kotlin is available only

ProjectBuilder tests with no kotlin dependency for example

Signed-off-by: Paul Merlin <paul@gradle.com>

  1. … 3 more files in changeset.
Merge branch 'release'

  1. … 2 more files in changeset.
Upgrade Kotlin DSL to 1.0.4

  1. … 1 more file in changeset.
Merge branch 'release'

  1. … 3 more files in changeset.
Upgrade Kotlin DSL to 1.0.3

Merge branch 'release'

Upgrade Kotlin DSL to 1.0.2

Upgrade Kotlin DSL to 1.0.1

With proper IDE support for accessors involving default package types.

Merge branch 'release'

Upgrade to Kotlin DSL 1.0

  1. … 2 more files in changeset.
Merge branch 'release'

  1. … 7 more files in changeset.
:arrow_up: gradle/kotlin-dsl to 1.0-rc-14

Signed-off-by: Paul Merlin <paul@gradle.com>

Remove links from build scans created on Travis

- Remove report links (only works on TC)

- Remove links to `e.grdev.net` GE instance for current commit

  1. … 1 more file in changeset.
Upgrade Kotlin DSL to 1.0-rc-13

Upgrade Kotlin DSL to 1.0-rc-12

Upgrade to Kotlin DSL 1.0-rc-11

Upgrade Kotlin DSL to 1.0-rc-10

Upgrade Kotlin DSL to 1.0-rc-9

Upgrade Kotlin DSL to 1.0-rc-8

Don't cache patchExternalModules for slow internet

Running with `-Dslow.internet.connection=true` or setting

`systemProp.slow.internet.connection=true` disables now caching

of `patchExternalModules` since the artifact to download is really big

and it may be faster to build it locally.

  1. … 2 more files in changeset.
Upgrade Kotlin DSL to 1.0-rc-7

Upgrade Kotlin DSL to 1.0-RC6

  1. … 2 more files in changeset.
Upgrade Kotlin DSL to 1.0-RC5

  1. … 2 more files in changeset.
Upgrade Kotlin DSL `1.0-rc-{2 => 3}`

  1. … 2 more files in changeset.
Upgrade Kotlin DSL `1.0-rc-{1 => 2}`

Also:

- update the release notes

- update the release features

  1. … 2 more files in changeset.
Upgrade Kotlin DSL `0.19.5 => 1.0-rc-1`