Gradle

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Merge pull request #10719 from gradle/wolfs/must-run-after-finalizers

Add a test to reproduce finalizer/mustRunAfter behaviour

Fix Kotlin DSL provider modes for backwards compatibility

Signed-off-by: Paul Merlin <paul@gradle.com>

Fix Kotlin DSL provider modes for backwards compatibility

Signed-off-by: Paul Merlin <paul@gradle.com>

Fix Kotlin DSL provider modes for backwards compatibility

Signed-off-by: Paul Merlin <paul@gradle.com>

Fix Kotlin DSL provider modes for backwards compatibility

Signed-off-by: Paul Merlin <paul@gradle.com>

Create build scans and enable build cache for triggers

Create build scans and enable build cache for triggers

Emit lower bound for generic types of Kotlin DSL accessors

Fixes #10772

Address review feedback

Coverage for optimized multi-script model payloads

Signed-off-by: Paul Merlin <paul@gradle.com>

Coverage for optimized multi-script model payloads

Signed-off-by: Paul Merlin <paul@gradle.com>

Coverage for optimized multi-script model payloads

Signed-off-by: Paul Merlin <paul@gradle.com>

Coverage for optimized multi-script model payloads

Signed-off-by: Paul Merlin <paul@gradle.com>

Merge pull request #10779 from gradle/wolfs/profiler/cross-build

Use Gradle profiler for running cross build tests

Distinguish Kotlin DSL provider classpath and lenient modes

Classpath mode is required for Kotlin DSL scripts TAPI models

Lenient mode is not

Lenient mode is useful when an editor queries a script

Lenient mode shouldn't be used when querying for all build scripts at

IDE import time

Signed-off-by: Paul Merlin <paul@gradle.com>

Distinguish Kotlin DSL provider classpath and lenient modes

Classpath mode is required for Kotlin DSL scripts TAPI models

Lenient mode is not

Lenient mode is useful when an editor queries a script

Lenient mode shouldn't be used when querying for all build scripts at

IDE import time

Signed-off-by: Paul Merlin <paul@gradle.com>

Distinguish Kotlin DSL provider classpath and lenient modes

Classpath mode is required for Kotlin DSL scripts TAPI models

Lenient mode is not

Lenient mode is useful when an editor queries a script

Lenient mode shouldn't be used when querying for all build scripts at

IDE import time

Signed-off-by: Paul Merlin <paul@gradle.com>

Distinguish Kotlin DSL provider classpath and lenient modes

Classpath mode is required for Kotlin DSL scripts TAPI models

Lenient mode is not

Lenient mode is useful when an editor queries a script

Lenient mode shouldn't be used when querying for all build scripts at

IDE import time

Signed-off-by: Paul Merlin <paul@gradle.com>

Merge branch 'master'

Fix groovydoc

Signed-off-by: Paul Merlin <paul@gradle.com>

Fix groovydoc

Signed-off-by: Paul Merlin <paul@gradle.com>

Fix groovydoc

Signed-off-by: Paul Merlin <paul@gradle.com>

Fix groovydoc

Signed-off-by: Paul Merlin <paul@gradle.com>

Reuse precompiled script files collection

Signed-off-by: Paul Merlin <paul@gradle.com>

Reuse precompiled script files collection

Signed-off-by: Paul Merlin <paul@gradle.com>

Reuse precompiled script files collection

Signed-off-by: Paul Merlin <paul@gradle.com>

Reuse precompiled script files collection

Signed-off-by: Paul Merlin <paul@gradle.com>

Add `@Deprecated` configurations to the Kotlin accessors

WIP - Add more details

Show deprecation warnings for work validation warnings (#10707)

Show deprecation warnings for work validation warnings

Fix WorkerExecutorFixture