Gradle

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Let code generation always use same line separators

in order to produce reproducible outputs

Signed-off-by: Paul Merlin <paul@gradle.com>

Fix GenerateScriptPluginAdapters task input/output annotations

And let :*:validateTaskProperties fail the build on warnings

Signed-off-by: Paul Merlin <paul@gradle.com>

Fix wrong assertion in ArtifactHandlerExtensionsTest

Signed-off-by: Paul Merlin <paul@gradle.com>

Polish `AbstractPluginTest`

- Move utility method closer to usage

Always resolve the script classpath against the imported project dir

To account for subprojects outside the root project directory.

This commit temporarily breaks the support for nested projects like

the ones found in `kotlin-dsl/samples` which shall be restored in a

subsequent commit.

Resolves #1231

Fix deprecation warning in buildSrc

Signed-off-by: Paul Merlin <paul@gradle.com>

Update wrappers to latest snapshot distro

    • -1
    • +1
    /gradle/wrapper/gradle-wrapper.properties
  1. … 24 more files in changeset.
Merge pull request #7966 from gradle/eskatos/kotlin-dsl/deferred-lambda

Accept Kotlin lambdas as a lazy construct for e.g. files

Merge pull request #7946 from gradle/eskatos/docs/resolver-logs-cleanup

Document kotlin-dsl IDE resolver logs cleanup

Fix Javadoc tags with are not supported by HTML5

JDK11 complains some unsupported Javadoc tags, make it happy:

- <tt> -> <code>

- <table summary='xx'> -> <table><caption>xx</caption>

- <a name='xx'> -> <a id='xx'>

  1. … 4 more files in changeset.
Fix Javadoc tags with are not supported by HTML5

JDK11 complains some unsupported Javadoc tags, make it happy:

- <tt> -> <code>

- <table summary='xx'> -> <table><caption>xx</caption>

- <a name='xx'> -> <a id='xx'>

  1. … 4 more files in changeset.
Upgrade testFixture Groovy to 2.5.4

Upgrade testFixture Groovy to 2.5.4

Switch build JDK to OpenJDK 11 in Gradle (#7810)

Previously we have the following checks:

- The JDK used in `packageBuild` and `promoteBuild` must be Oracle JDK 9.

- If remote cache is enabled, the build JDK must be Oracle JDK 9 (same as TC).

Now we're going to switch to OpenJDK 11 on TC https://github.com/gradle/gradle/pull/7809 , correspondingly, we change these checks to OpenJDK 11.

Switch build JDK to OpenJDK 11 in Gradle (#7810)

Previously we have the following checks:

- The JDK used in `packageBuild` and `promoteBuild` must be Oracle JDK 9.

- If remote cache is enabled, the build JDK must be Oracle JDK 9 (same as TC).

Now we're going to switch to OpenJDK 11 on TC https://github.com/gradle/gradle/pull/7809 , correspondingly, we change these checks to OpenJDK 11.

Fix incorrect macos OperatingSystemFamily

Fix incorrect macos OperatingSystemFamily

Publish 5.1-20181207235007+0000

Merge remote-tracking branch 'origin/release'

Use convention method for target machines property

Don't use Java 9 `of` method

So the test works on Java 8 as well.

Merge pull request #7937 from gradle/lacasseio/native/visual-studio

Support for architecture in Visual Studio IDE

Ignore failing tests

Merge remote-tracking branch 'origin/gh/stable-native/unit-test-architecture' into release

* origin/gh/stable-native/unit-test-architecture:

Fix issue when running component tests with 64 bit toolchain

Fix issue with relocate task

Fix issue with setting test binary when main component has not been set

Fix issues with unit testing libraries

Target machine support for xctest

Add architecture support for CppUnit tests

Merge pull request #7896 from gradle/marc/insights/1696-tapi-transform-events

Report transform progress events and dependencies to TAPI progress listeners

Update notes.md

    • -3
    • +5
    /subprojects/docs/src/docs/release/notes.md
Merge pull request #7843 from gradle/wolfs/execution-engine/tests

Add test coverage for the execution engine

Let AbstractTask @RequiresNonFinalSubClasses

Signed-off-by: Paul Merlin <paul@gradle.com>

Introduce @RequiresNonFinalSubClasses

Signed-off-by: Paul Merlin <paul@gradle.com>

Update build-in scan plugin version to 2.1 (#7970)