Gradle

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Merge pull request #4577 from gradle/hansd/gradlebuildNamespace

Added new namespace to plugins and more modularization in buildSrc

TeamCity change in 'Gradle :: Util :: Performance' project: general settings of 'AdHoc Performance Scenario - Linux' build configuration were updated

Added some test coverage for buildPath/buildIdentifier in various build compositions.

Fixed tooling api int tests.

Fixed build initialization for `GradleBuild` task.

Fixed compile error.

Moved responsibility for determining the `BuildIdentifier` for a build into core, from dependencyManagement project, and changed the logic to always produce the same identifier for a given build. Previously, the id could change based on _when_ the id was queried. For example, any kind of dependency resolution in an init script would lead to all build having `:` as their build id.

In this change the build id for all nested builds is calculated based on the root directory of the build.

  1. … 6 more files in changeset.
Added gradlebuild namespace to plugins and more modularization in buildSrc

- Added to all plugins in buildSrc "gradlebuild." to their id

- Shortened plugin names

- Added ide and docs as additional modules

- Applied java-library plugin to Kotlin projects to model dependencies

  1. … 72 more files in changeset.
Remove unnecessary workaround from buildSrc

This is now built into the `java-gradle-plugin`

Fix archiving artifacts for buildSrc test failures

This was not working anymore since buildSrc is now a multiproject build.

Changed IDE plugins so that they use strongly typed objects across Gradle project boundaries to describe the IDE projects produced for the project, rather than attempting to encode information into file names and existing `PublishArtifact` properties.

Changed the Eclipse and Visual Studio plugins to expose a single IDE project object rather than a bunch of individual "artifacts" across project boundaries. In particular, the Visual Studio plugin no longer exposes artificial artifacts to describe each configuration of the Visual Studio project.

  1. … 13 more files in changeset.
Merge pull request #4574 from gradle/hansd/buildSrcRefactoring

Moved more scripts to buildSrc and refactored buildSrc

Moved more scripts to buildSrc and refactored buildSrc

- Moved wrapper.gradle.kts to buildSrc

- Moved resumeBuild.gradle to buildSrc

- Moved minifiedDependencies.gradle to buildSrc

- Moved dependenciesCheck.gradle to buildSrc

- Moved updateReleasedVersions.gradle to buildSrc

- Introduced configuration submodule for developer focused configuration

- Created buildSrc submodule for buildquality

- Created buildSrc submodule for packaging

- Created buildSrc submodule for profiling

- Created buildSrc submodule for versioning

- Introduced org.gradle.gradlebuild naming convention

- Introduced project-groups file for providing groups of subprojects

    • -0
    • +32
    /buildSrc/subprojects/buildquality/buildquality.gradle.kts
    • -0
    • +9
    /buildSrc/subprojects/configuration/configuration.gradle.kts
    • -0
    • +24
    /buildSrc/subprojects/packaging/packaging.gradle.kts
  1. … 27 more files in changeset.
Moved more scripts to buildSrc and refactored buildSrc

- Moved wrapper.gradle.kts to buildSrc

- Moved resumeBuild.gradle to buildSrc

- Moved minifiedDependencies.gradle to buildSrc

- Moved dependenciesCheck.gradle to buildSrc

- Moved updateReleasedVersions.gradle to buildSrc

- Introduced configuration submodule for developer focused configuration

- Created buildSrc submodule for buildquality

- Created buildSrc submodule for packaging

- Created buildSrc submodule for profiling

- Created buildSrc submodule for versioning

- Introduced org.gradle.gradlebuild naming convention

- Introduced project-groups file for providing groups of subprojects

    • -0
    • +32
    /buildSrc/subprojects/buildquality/buildquality.gradle.kts
    • -0
    • +9
    /buildSrc/subprojects/configuration/configuration.gradle.kts
    • -0
    • +24
    /buildSrc/subprojects/packaging/packaging.gradle.kts
  1. … 27 more files in changeset.
Annotate test that requires network access

Inline `ModuleState` into `ComponentState` as `ComponentSelectionState`

Avoid creating a new list of incoming edges when all are transitive

Test demonstrating bug with excludes and dependency constraints

When a dependency constraint is 'realized' into a hard dependency, it provides

an additional path to the target module, one that has no exclusions defined.

As a result, any dependency exclusions defined on other dependencies will

be ignored.

Dependency constraints are not dependencies, and should not invalidate excludes

defined on dependencies.

This is the underlying cause of #4567.

Test demonstrating bug with dependency constraints

When a constraint (pending dependency) is 'realized' into a hard dependency

by the discovery of a second dependency to the same module, the constraint

will remain as a hard dependency will remain even when second dependency is

evicted from the graph.

Merge pull request #4573 from gradle/hansd/moveScriptsToBuildSrc

Moved wrapper and dependency resolution check to buildSrc

Fixed Xcode plugin so that Xcode workspace generation does not compile Swift libraries from included builds, only those libraries in source dependencies.

Changed some test coverage to verify that `gradle :xcode` produces a functional workspace, rather than `gradle xcode` producing one by coincidence.

Moved wrapper and dependency resolution at configuration time check to buildSrc

- Fixed bug in dependency resolution script displaying always the root project name

    • -16
    • +0
    /gradle/noDependencyResolutionDuringConfiguration.gradle.kts
Added some Xcode plugin test coverage for multi-project and composite builds.

Added missing artifacts to cross version test fixtures

- Added missing project dependency

- Set libsRepository.required to true

Added some test coverage for Visual Studio plugin, to ensure the right thing happens for multi-project and composite builds.

Fixed bug in CleanupPlugin

- Fix the mustRunAfter relationship for killExistingProcessesStartedByGradle

Refactored distribution test logic

- Extracted clean up tasks for root project into separate plugin

- Migrated and refactored distributionTesting.gradle.kts into buildSrc

- Changed order for applying the plugins

    • -2
    • +16
    /buildSrc/subprojects/cleanup/cleanup.gradle.kts
    • -134
    • +0
    /gradle/distributionTesting.gradle.kts
Accepted breaking change.

Changed the IDEA plugin to use the same API to determine the IDEA modules to include in the IDEA project as the Xcode and Visual Studio plugins use to determine the projects to include their workspaces, rather than include two not-quite-the-same duplicate implementations of this logic in the IDEA plugin.

Changed all IDE plugins to consistently use `IdeArtifactRegistry` to cross project boundaries, rather than sometimes using this and sometimes reaching down into dependency management internals (the registry implementation still does this, but at least it's in one spot now).