Gradle

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Revert "Patch teamcity.build.tempDir property"

This reverts commit f80a5975b4329f6625a86eb45b8a73cf69e05384.

    • -21
    • +0
    /gradle/remove-teamcity-temp-property.gradle
Revert "Ignore failing test for now"

This reverts commit 09f28a51ae9b673d8693b07b93f7a66cf31af982.

Add XCTest plugin reference chapter

    • -0
    • +12
    /subprojects/docs/src/docs/dsl/dsl.xml
    • -0
    • +38
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.tasks.LinkMachOBundle.xml
    • -0
    • +41
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.test.TestSuiteComponent.xml
    • -0
    • +38
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.test.xctest.SwiftXCTestSuite.xml
    • -0
    • +47
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.test.xctest.tasks.InstallXCTestBundle.xml
    • -0
    • +47
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.test.xctest.tasks.XCTest.xml
    • -0
    • +270
    /subprojects/docs/src/docs/userguide/xctest_plugin.adoc
  1. … 5 more files in changeset.
Add XCTest plugin reference chapter

    • -0
    • +12
    /subprojects/docs/src/docs/dsl/dsl.xml
    • -0
    • +38
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.tasks.LinkMachOBundle.xml
    • -0
    • +41
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.test.TestSuiteComponent.xml
    • -0
    • +38
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.test.xctest.SwiftXCTestSuite.xml
    • -0
    • +47
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.test.xctest.tasks.InstallXCTestBundle.xml
    • -0
    • +47
    /subprojects/docs/src/docs/dsl/org.gradle.nativeplatform.test.xctest.tasks.XCTest.xml
  1. … 7 more files in changeset.
Fix typos in Swift and C++ chapters

Fix typos in Swift and C++ chapters

Fix typos in Swift and C++ chapters

Fix patch

    • -5
    • +7
    /gradle/remove-teamcity-temp-property.gradle
Use Java 8 syntax where possible

Revert "Ignore failing test for now"

This reverts commit 90e15b3e55fbba276f94e96aea8bfed7ab9fa85a.

Patch teamcity.build.tempDir property

    • -0
    • +21
    /gradle/remove-teamcity-temp-property.gradle
Patch teamcity.build.tempDir property

    • -0
    • +21
    /gradle/remove-teamcity-temp-property.gradle
Print property

    • -0
    • +19
    /gradle/remove-teamcity-temp-property.gradle
Ignore failing test

Ignore failing test

Polish code: do not use FileCollection when visiting properties

Do not use FileCollection in UnitOfWork

Polish code: do not use FileCollection when visiting properties

Polish code: do not use FileCollection when visiting properties

Polish code: do not use FileCollection when visiting properties

Pass Property instances to property visitor methods

This allows us to add more functionality for different kinds of properties without the need to pass `Supplier`s.

Update wrapper

    • -1
    • +1
    /gradle/wrapper/gradle-wrapper.properties
Update wrapper

    • -1
    • +1
    /gradle/wrapper/gradle-wrapper.properties
Update wrapper

    • -1
    • +1
    /gradle/wrapper/gradle-wrapper.properties
Fix Kotlin compilation warnings

- Suppress `unchecked_cast` warnings

- Rename parameters to match base definition

- Remove unnecessary casts

- Remove unnecessary/duplicate interface implementation

- Help the compiler understand the expressions are indeed used

Fix Kotlin compilation warnings

- Suppress `unchecked_cast` warnings

- Rename parameters to match base definition

- Remove unnecessary casts

- Remove unnecessary/duplicate interface implementation

- Help the compiler understand the expressions are indeed used

Fix Kotlin compilation warnings

- Suppress `unchecked_cast` warnings

- Rename parameters to match base definition

- Remove unnecessary casts

- Remove unnecessary/duplicate interface implementation

- Help the compiler understand the expressions are indeed used

Fix Kotlin compilation warnings

- Suppress `unchecked_cast` warnings

- Rename parameters to match base definition

- Remove unnecessary casts

- Remove unnecessary/duplicate interface implementation

- Help the compiler understand the expressions are indeed used

Full recompilation with annotation processor (#9917)

This fixes #9871

We don't want to support annotation processing with incremental Groovy compilation because there're too many complicated corner cases - we simply disable Groovy incremental compilation if any Java annotation processors detected.

Print stacktrace