Gradle

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Publish 5.0-20181108172348+0000

Rebaseline help on the gradle build comparing the build

Signed-off-by: Paul Merlin <paul@gradle.com>

    • -1
    • +1
    /subprojects/performance/templates.gradle
Merge branch 'release'

Refine kotlin_dsl.adoc

Signed-off-by: Paul Merlin <paul@gradle.com>

Update release notes link to Kotlin DSL for 1.0.2

Signed-off-by: Paul Merlin <paul@gradle.com>

    • -1
    • +1
    /subprojects/docs/src/docs/release/notes.md
Merge pull request #7670 from gradle/bamboo/release/kotlin-dsl-1.0.2

Upgrade Kotlin DSL to 1.0.2

Make the changes to the initial value of properties created via factory more prominent

    • -1
    • +5
    /subprojects/docs/src/docs/release/notes.md
More tidying of Ant migration chapter

add http retries to the 5.0 release notes

    • -0
    • +6
    /subprojects/docs/src/docs/release/notes.md
Polish `ClassyclePlugin.kt`

- Remove unnecessary `project` reference

- Fix indentation

Polish `execution.gradle.kts`

- Favour plugin accessor over string id for code navigation

Merge pull request #7669 from gradle/js/docs/remove-duplicate-heading

remove duplicate heading from release notes

remove duplicate heading from release notes

    • -2
    • +0
    /subprojects/docs/src/docs/release/notes.md
Upgrade Kotlin DSL to 1.0.2

Toward 1.0.3

Prepare 1.0.2 release

Update wrappers to latest snapshot distro

    • -1
    • +1
    /gradle/wrapper/gradle-wrapper.properties
  1. … 24 more files in changeset.
Bump :plugins version

Signed-off-by: Paul Merlin <paul@gradle.com>

Merge pull request #1241 from gradle/eskatos/plugins/kotlin-versions

Remove dependencies pinning from `embedded-kotlin` and add cross-kotlin-version coverage

Merge pull request #7667 from gradle/eskatos/perf/integ-tests-use-kotlin-compiler-daemon

Let integration tests not opt-in to in-process kotlin compiler

Correct Javadoc of SingleDepthFileAccessTracker

Merge pull request #7610 from gradle/js/docs/start-upgrading-from-gradle-5.0-guide

Update release notes and upgrade guide to reflect 5.1 release

Integ test should reuse kotlin compiler daemon

to prevent OOME

by not setting -Dkotlin.compiler.execution.strategy=in-process

Signed-off-by: Paul Merlin <paul@gradle.com>

Merge pull request #7663 from gradle/bamboo/release/kotlin-dsl-1.0.1

Upgrade Kotlin DSL to 1.0.1

Bump :plugins

Signed-off-by: Paul Merlin <paul@gradle.com>

`embedded-kotlin` plugin does not pin dependencies anymore

Signed-off-by: Paul Merlin <paul@gradle.com>

Change the tooling API provider to route logging to the client stdout and stderr streams in a similar way to the command-line client.

When not producing rich output the tooling API writes errors to the stderr stream (same as when the command-line client is not run from a console), and when producing rich output the errors are written to the stdout stream (same as when the command-line client is run from a console).

Upgrade Kotlin DSL to 1.0.1

With proper IDE support for accessors involving default package types.

Toward 1.0.2

Publish 5.0-20181108000033+0000