Dashboard

Merge branch 'release'

Publish 5.1-rc-1

Don't publish CACHE_MISS tag in buildScanPluginPerformanceTest

Don't publish CACHE_MISS tag in buildScanPluginPerformanceTest

Use opacity

Revert "Merge branch 'sg/lazy/publish-register-2' into release"

This reverts commit 975120ec3997139e2e81e9ad4c03df89fa0748e5, reversing

changes made to 2eb24bc6b76a7d76b97036ca2c716730bc156d76.

  1. … 10 more files in changeset.
Merge pull request #8021 from gradle/sg/lazy/docs

Update user manual to fully de-incubate the task configuration avoidance

First go at pushing empty source cleanup to execution engine

First go at pushing empty source cleanup to execution engine

Refactor/reword task config avoidance chapter for clarity

Merge branch 'sg/lazy/publish-register-2' into release

* sg/lazy/publish-register-2: (24 commits)

Restrict magic handling to just AbstractArchiveTasks for now

Restore removed types that were used by the plugin-publish plugin

Try fixing Android and Gradleception builds that relied on undocumented behavior

Fix remaining unit tests

Almost all tests fixed

Fix unit tests

Make sure war is added to the default artifact set

Rename some local variables to match actual task name

Fix unit tests

Copy builtBy information from PublishArtifact

Make checkstyle happy

Always have an artifact name for an abstract archive task

Remove deprecation warning for now

Fix conversion from unknown Provider to Provider<FileSystemLocation>

PublishArtifact classifiers should be non-null

Register provider to output file

Fix sanity check failures

Fix unused import

Fix types of Transformer<ArtifactFile, Object>

Remove unused import

...

Use `DependencyInjectingInstantiator` for (almost) all instantiation, so that service injection can be made available for all types and to make instantiation behaviour and error reporting more consistent.

Not all types have services available for injection yet, for example the elements of containers created using `Project.container()` or extensions attached to types other than `Project`.

There are some differences in behaviour due to backwards compatibility, wrt the `@Inject` annotation and also null constructor parameters. These differences can be removed in the future.

Use `DependencyInjectingInstantiator` for (almost) all instantiation, so that service injection can be made available for all types and to make instantiation behaviour and error reporting more consistent.

Not all types have services available for injection yet, for example the elements of containers created using `Project.container()` or extensions attached to types other than `Project`.

There are some differences in behaviour due to backwards compatibility, wrt the `@Inject` annotation and also null constructor parameters. These differences can be removed in the future.

Use `DependencyInjectingInstantiator` for (almost) all instantiation, so that service injection can be made available for all types and to make instantiation behaviour and error reporting more consistent.

Not all types have services available for injection yet, for example the elements of containers created using `Project.container()` or extensions attached to types other than `Project`.

There are some differences in behaviour due to backwards compatibility, wrt the `@Inject` annotation and also null constructor parameters. These differences can be removed in the future.

Expose BuildOutputCleanupRegistry

Restrict magic handling to just AbstractArchiveTasks for now

Add a note to prefer the lazy API for task constructor construction

Rewrote the task configuration section to put lazy APIs more prominent

Upgrade default Checkstyle version to 8.15 for compatibility with Java 11

Signed-off-by: Rodrigo B. de Oliveira <rodrigo@gradle.com>

Upgrade default Checkstyle version to 8.12 for compatibility with Java 11

Signed-off-by: Rodrigo B. de Oliveira <rodrigo@gradle.com>

Merge pull request #8019 from gradle/lptr/execution/small-improvements

Small improvements for execution engine

Let buildSrc kotlin code satisfy type/file name ktlint rule

those files only contains a single type

they should be named accordingly

Signed-off-by: Paul Merlin <paul@gradle.com>

Let buildSrc kotlin code satisfy comment formating ktlint rule

Signed-off-by: Paul Merlin <paul@gradle.com>

Update ktlint-convention plugin to 0.2.0

and new plugin id

Signed-off-by: Paul Merlin <paul@gradle.com>

Merge pull request #7551 from tbroyer/issue-4956-annotationProcessorGeneratedSourcesDirectory

Set default value to annotationProcessorGeneratedSourcesDirectory

Restore removed types that were used by the plugin-publish plugin

Try fixing Android and Gradleception builds that relied on undocumented behavior

Resolve before execution state early

Resolve before execution state early

Remove unnecessary invocation of taskInputsListener

We'd be calling with an empty file collection anyway.